RecipLatView
SCD Reciprocal Lattice Viewer

Introduction:

The reciprocal lattice viewer is designed to allow users to work with single
crystal diffraction data in a three-dimensional environment by displaying
voxels in reciprocal space that correspond exactly to time-of-flight
histogram bins from the area detectors.

Getting Started:

Launching from ISAW

® To launch the reciprocal lattice viewer from ISAW, follow the menus:
Macros > Instrument Type > TOF_NSCD > SCDReciprocallLattice

® A new window will open containing several options.
Data Directory - Choose the directory where run data is stored.
Calibration File - Select a calibration file if you have one.
Orientation Matrix - Select an orientation matrix if you have one.

Run Numbers - This specifies the run numbers to be used.
Multiple runs should be separated by commas; a set of runs can be
represented by separating the beginning and end value with a
colon. For example: 8336:8339, 8341

Threshold Level - This is used to limit how many bins (counts) are
displayed in the viewer. If the value is set too low then many low-
count bins will be included causing the system to slow down. 60 is
usually a safe starting value.

Show Contours - Selecting this option adds contour lines to the
voxels; turning this option on requires extra computing power.

Contour Level - This is used to limit how many contour
[somethings] are displayed in the viewer. If “Show Contours” is
used then this should initially be set to a higher number.



Show Regions - This is used to show the volume covered by the
detector.

Show HKL Markers - This option allows the user to turn show
marks at integer HKL points. Selection of this option requires that
an orientation matrix is loaded.

Calculate FFTs — This option allows for initial calculation of FFTs
when the data is loaded.

® When you are finished, press Apply and the Reciprocal Lattice Viewer
will open.

Launching from a command line

® To launch the reciprocal lattice viewer from a command line type the
following:

java -mx1000M DataSetTools.trial. GL_RecipPlaneView
-D/usr2/ARGONNE_DATA/SCD_MOSIH_DUAL -T60 -Cinstprm.dat -
R8760:8771

-D specifies the data directory

-T specifies an initial threshold

-C specifies the name of a calibration file in the data
directory

-R specifies a sequence of run numbers

-O specifies an orientation matrix in the data directory

Note:

If an orientation matrix is specified, the reciprocal axes a*,b*,c* will be
displayed. If no orientation matrix is specified or found, the axes are the
Qx,Qy,Qz axes in "laboratory" coordinates.

If no calibration file is specified, the engineering values for the detector
size and position are used.

Available Controls:




View Controls
® The view controls are always at the top of the control panel.

Altitude — This controls the angle above or below the horizontal
plane in the viewing window.

Azimuth — This controls rotation around the vertical axis in the
viewing window.

Distance — This controls the distance from the origin displayed in
the viewing window.

Projection — This option allows the user to choose between
orthographic projection and perspective projection.

Tip: Use your keyboard's arrow keys for fine adjustment.

View Tab

Peaks Threshold - This controls the cutoff level above which bins
are displayed and used in subsequent processing.

Iso-surface Threshold - This controls the single level at which iso-
level contours are drawn. Lower values for this setting require
more computing power.

Iso-surface - This option allows the user to turn on/off iso-surfaces
in the viewing window.

Detector Coverage - This option allows the user to turn on/off a
visual representation of the detector's coverage area.

Integer HKL points - This option allows the user to turn on/off

marks at integer HKL points. This only works if an orientation
matrix was loaded.

Calculate FFTs of Projections



This operation is used to approximate the direction of normals for
planes in a crystalline lattice within reciprocal space. The direction
of three linear independent plane normals can then be used to
generate an orientation matrix for the sample.

FFT projects the Q values in reciprocal space into one-dimensional
lines pointing in various directions. These lines are Fourier
transformed to identify directions that represent normals to families
of planes in reciprocal space. The Fourier transformed projected
data is displayed as rows in an image view where peaks are
arranged in order of increasing d-spacing.

The plane normals are displayed in the three-dimensional view as a
sequence of light blue boxes pointing in the direction of the normal.
The distance between these boxes corresponds to the reciprocal
length of an edge of the unit cell in real space. The d-spacing can
be found on the border of the graph part of the image view.

Planes Tab

Qxyz Readout - This readout displays the Qxyz coordinates of the
currently selected peak.

Origin Control - This is used to change the view center of the
viewer window by clicking on a peak and then pressing the Select
button. Pressing the Select button will also choose the initial point
for two user-specified vectors that are used to identify a family of
planes. The Reset button will reset the view center to the Qxyz
origin.

( +) Control - This is used to change the endpoint of one user-
specified vector to the last peak that the user clicked on.

( * ) Control - This is used to change the endpoint of a second
user-specified vector to the last peak that the user clicked on.

Constant h Planes, Constant k Planes, Constant | planes

® These allow the user to specify a family of planes with a
constant h, k, or | value in reciprocal space.

User - Clicking on User-> will create the constant h, k, or |
plane information based on the normal to the plane



determined by the two user-specified vectors + and *.

FFT - Clicking FFT-> will create the constant h, k, or | plane
information based on the normal direction from the last
selected row in the FFT image view window.

Filter On/Off — This option allows the user to restrict visible
data to those which lie within 0.1 units of an integer value.

® The normal vector and d-spacing that correspond to the
family of planes defined are displayed in the control
windows. The values for d-spacing can be edited if better
values are known.

Write Orientation Matrix

® \When constant h, k, and | planes have been defined, the
corresponding orientation matrix can be written to a file.

Write Peak Data File

® A list of the bins above the specified threshold can be
written to a file.



Exercise: Determining the Orientation Matrix for Oxalic Acid
Using the Reciprocal Lattice Viewer

The SCD Reciprocal Lattice Viewer in ISAW has proven to be very useful in
determining the orientation matrix of a sample when it is difficult to index the
peaks using Blind using the Initial Wizard. This exercise will take you through the
steps needed to load data into the viewer, determine the unit cell and write an
orientation matrix.

The data for oxalic acid at 80 K are run files 9164:9183 and are included in the
ISAW tutorial. You will not need all of these data files to determine the unit cell
and write an orientation matrix.

1. Start the viewer by following the menus: Macros > Instrument Type >
TOF_NSCD > SCDReciprocallLattice

& SCDReciprocall attice

Operation SCDReciprocall attice

Data_Directony !ITutDriaIIOxalic acid| Browse
Calibration_File !_tuturiallinatprm.dat Browse
Orientation_Matrix iC:IisawISampleRur Browse |
Run_Numbers 9164:9167 |
Threshold_Level B0 |
Show_ Contours |

Contour_Level |50.0 |
Show_Regions L]

Show HKL Marks ]

Calculate_FFTs L]

Result
Apphy Ezit Help

2. Load the run files 9164:9167 from the directory the data is in. Use the
calibration file instprm.dat from the ISAW tutorial. You do not need an
orientation matrix for this exercise — you will determine this from the raw
data using the reciprocal space viewer.

Use the defaults for the threshold level and contour level. In the case that
the data is weaker than the data for this exercise (orientation data taken
on SCD is often a 30 minute histogram and therefore not as many counts
may be collected at the detector), you can reduce the threshold level to
increase the number of reflections included in the viewed data set. Do not



check the other boxes at this time.

Click Apply to view the data from the run files in the reciprocal space
viewer.

2 Reciprocal Lattice Plane Viewer
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Your data screen should look similar to this. The red, green and blue axes
are the x, y and z “laboratory” axes in Q-space (reciprocal space),
respectively. The origin of the plot is clearly labeled where these axes
meet. Each voxel is an individual reflection at its x, y and z position in
reciprocal space. Clicking on the Planes tab and then clicking on a
reflection will give you the Qxyz coordinates of that reflection.

Use the Altitude and Azimuth adjusters to move the reflections around
until you have aligned the reflections into a series of planes. You can use
the arrow keys on the keyboard to fine-tune the movement.

. You can use the constant h, k and | plane function to find the d-spacings
and write an orientation matrix for the sample. First, orient the reflections
so that you are viewing a family of planes: if you used runs 9164:9167, try
moving the distance to approximately 31.8, the altitude to 43.1 and the
azimuth to 44.1. You should obtain a screen like the following:
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Using the Planes tab, we can now define a plane of constant h, k or | by
clicking on three non-linear reflections within one of these planes. Clicking on
the User-> button will calculate the normal to our defined plane, and you
should then have the interplanar d-spacing between the family of planes
shown above. To step through the process, you can follow these steps:

a. Zoom back in to a distance where you can see the planes more
closely, like 11.6.

b. Use the azimuth slider or your keyboard to move the planes to one
side, so that instead of having all of the reflections lined up
precisely, you can see more of the reflections that make up these
families of planes. Try an azimuth angle of 49.6.

c. Now you should redefine your origin and choose two other
reflections that are non-collinear with your origin of choice. Click on
a reflection in a plane and click on Select under the origin to define
that reflection as the new origin. Do the same using two other
reflections in that plane and clicking on Select + and Select *. The
result should be a user defined plane:
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d. You can see now that the origin is no longer at 0, 0, O; it is the
central reflection surrounded by a box. (Don’t worry; you can reset
the origin to 0, 0, 0 by clicking on Reset under origin.) The two
other reflections chosen by Select + and Select * have a vector
drawn to them. The three reflections are non-collinear and define a
plane.

e. Click on User-> in a Constant h Planes box to calculate the normal
to the defined plane. The result in the d-spacing box should be in
the neighborhood of 6.1 — exactly what we would expect for one of
the unit cell lengths for oxalic acid. Notice that if you keep clicking
on the User-> button, the d-spacing may keep changing until it
reaches a final value.

f. Reset the origin and locate a different family of planes. Try an
altitude of 22.9 and an azimuth of -64.3. You will notice that the
previously drawn vectors, now centered at the origin of 0, 0, O, are
pointing to two different planes. This is a good measure that you
have located a different family of planes than you did previously at
the beginning of step 3.



£ Reciprocal Lattice Plane Viewer

|rview Control

| ’—mtltude 232 s’—‘

Bziruth 2 -£4.37

S

Distance 24.7

—

Projection

[¥] Orthographic

View | Pla

nes |

fo.

7

006, 5692, 2953

S| origin
Al e s
Al

o.000

o000

. 0000, 0.000

Select Resat

" i
H |

1.228

Al zlzse

. 1.ag6, 2 EED

Select+

AAr )

A o

z.790

Aar: e 180

. o2.1E7. EB.E3S

Select™

“0.8Z551.
| [ENEREES!

rConstant b Planes

0.83811 -0.2328%
| = 0.n2228

-+ | Frrs [Fiterorr|no)

|| wezma:
| [ENEY

Al user= |

| Constart k Planes

| =

FFT-z EFi\telDFng[D]

f[Hezmal:

| (X

: User-»

“IrConstart | Planes

o

FFT-> |Filter OFF |1 [0]

Wit

e Orientation Matrix

Write Peak Data File

d-spacing should be approximately 3.4.

h. Find the third set of planes by resetting the origin and moving to an
altitude of 1.2 and an azimuth of -62.4. (In this orientation, the
plane to define runs horizontally.) The resulting d-spacing should
be around 12.1.

i. With three user defined unit cell parameters, you may now write an

orientation matrix by clicking on Write Orientation Matrix. You will
be prompted for a name for your matrix — give it a different one if
you have already determined an orientation matrix by other means
so you do not lose your previous work. You can view the resulting

matrix file by opening it with a text editor.
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g. Repeat steps 3a-3e for this family of planes. Calculate the normal
by clicking on User-> in the Constant k Planes box. The resultant




File Edit ‘iew Insert Format Help

Ded & ## @ B o
| -0.077989 0.151152 -0.003180
0.254670 0.1305826 0.012213
0.014029 -0.021043 -0,031750
6.116 3.4%0 12.15858 g89.525 73.990 89.733 249,407
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For Help, press F1 TR

You will notice that this resulting unit cell should be transformed to
the standard monoclinic setting to achieve the correct 3 angle of
106°, but the cell is correct for the material.

Click on Write Data Peak File to get a list of peaks for the
reflections shown in the viewer. The peak file that is written out by
the Reciprocal Space Viewer is not in the correct format to be
indexed by the matrix determined in this exercise.

Using the menu items in Macros > Instrument Type >
TOF _NSCD, it is possible to index the peaks, refine the least
squares matrix, transform the cell and integrate them in a manual
fashion, bypassing the Wizard Menu. You can follow these steps in
the Macros as if you were going through the Wizard itself once you
have a peaks file:

i. Search for peaks on the run file(s) using Macros >
Instrument Type > TOF_NSCD > find_multiple_peaks
(Initial Wizard Form 1). A filename.peaks file will be written
according to input under Experiment Name on the form.
This peaks file, unlike the one generated by the Reciprocal
Lattice Viewer, can be indexed using the determined matrix.

i. Use Macros > Instrument Type > TOF_NSCD > Jindex
(Initial Wizard Form 3) to index the Peaks file using the
matrix file written by the Reciprocal Lattice Viewer. If you
view the peaks file again, the peaks should be indexed with
hkl values.

iii. Use Macros > Instrument Type > TOF_NSCD > JScalar
(Initial Wizard Form 4) to search for alternate symmetries.
This may or may not give a proper transformation matrix.

iv. Use Macros > Instrument Type > TOF_NSCD > JLsqrs
(Initial Wizard Form 5) and the correct transformation matrix
of [[-1, 0, 0][0, 1, 1][O, O, 1]] to transform the monoclinic matrix
into the standard setting. Use a matrix with a different name
if you do not wish to overwrite your matrix determined using
the Reciprocal Lattice Viewer. Check your new transformed
matrix to insure that your new matrix s
correct:

11
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V. You should then use Macros > Instrument Type >
TOF_NSCD > Jindex (Initial Wizard Form 6) again with the
new matrix file to reindex the peaks file so they are
consistent with the transformed unit cell.

Still confused? There are future plans to include an option to index the peaks file
with a pre-determined matrix in Form 2 (JBlind) of the Initial Wizard in ISAW, so
that these steps through the Macros menu may be eliminated. These steps
should guide you, however, in transforming an orientation matrix in a non-
standard setting using the Macros menus in ISAW.

4. You may also use the Calculate FFTs of Projections option under the
View tab to write an orientation matrix and peaks file.

a. Click on the Calculate FFTs of Projections button in the View
pane. A new window will appear showing the Fourier transforms of
the reflections shown. Choose Options > Color Scale > Optimal
from the menu in the new window to have the FFTs appear as
described in the preceding documentation.
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b. Click on the first row containing the white boxes. The plane
normals are displayed in the three-dimensional view as a sequence
of light blue boxes pointing in the direction of the normal. The
distance between these boxes corresponds to the reciprocal length
of an edge of the unit cell in real space. The d-spacing can be
found on the border of the graph part of the image view.
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c. Here you can see how the 3.4 A cell edge relates to the family of
planes in the reciprocal space viewer as shown at the angles from
step 3.h. above. You can scroll through the Fourier transforms by
clicking through them or using the arrows on your keyboard. Click
on the d-spacing that corresponds to the 12.4 A cell edge to see
how this relates to the same graph.
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d. To use the Fourier transforms to define constant h, k or | planes:
select the d-spacing that best defines the interplanar spacing, then
click on FFT-> in the Constant h, k or | Planes window under the

Planes tab.

e. Follow the same procedure as for 3.1-k to write an orientation
matrix and peaks file.
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